Outage: Attachments
Resolved
The issue is resolved and attachments are now accessible.
Posted 8 months ago. Sep 14, 2017 - 13:13 PDT
Identified


We have identified an issue that causes attachments to be inaccessible in the US region. We are working to resolve this issue as quickly as possible.

For any questions, please contact ACL Support: https://support.acl.com
Posted 8 months ago. Sep 14, 2017 - 12:16 PDT