Outage: ACL Communities
Resolved
ACL Communities is back up and fully functional.
Posted 4 months ago. Jun 04, 2018 - 12:59 PDT
Investigating


We are currently investigating and will provide further updates.

For any questions, please contact ACL Support: https://support.acl.com
Posted 4 months ago. Jun 04, 2018 - 12:45 PDT
This incident affected: ACL Help & Learning (ACL Communities).