Incident: July 25th, 2017 - Issues impacting www.acl.com website
Resolved
The problems with www.acl.com have been resolved.

Thank you for your patience.
Posted 4 months ago. Jul 25, 2017 - 12:06 PDT
Identified
Issues identified with a 3rd party tool are causing issues on www.acl.com with web contact forms.

These problems should be resolved no later than noon pacific today.
Posted 4 months ago. Jul 25, 2017 - 10:24 PDT
This incident affected: ACL Web Site & Renewal Portal.