Outage in Reports Manager module and Impact Reports
Resolved
We have resolved the issue.

Thank you for your patience.
Posted about 1 month ago. Aug 18, 2017 - 10:36 PDT
Investigating
We are investigating an outage in Reports Manager module and downloading Impact Reports within Project Manager US region.
Posted about 1 month ago. Aug 18, 2017 - 10:03 PDT
This incident affected: ACL GRC - North America (ACL GRC - Project Manager).