Outage: ACL Support & Communities
Resolved
ACL Support & Communities is back online and fully operational.
Posted about 1 year ago. Nov 16, 2016 - 21:04 PST
Investigating


We are currently investigating the outage and will provide further updates.

For any questions, please contact ACL Support at 1-866-704-0581.
Posted about 1 year ago. Nov 16, 2016 - 17:07 PST
This incident affected: ACL Help & Learning (ACL Communities).