Outage: ACL Academy
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 17, 2016 - 01:44 PDT
Investigating


We are currently investigating the outage and will provide further updates.

For any questions, please contact ACL Support: https://support.acl.com
Posted 11 months ago. Aug 17, 2016 - 00:09 PDT
This incident affected: ACL Help & Learning (ACL Academy).